Vulnerability critical
Severity
critical
no CVSS

Axios npm Supply Chain Attack: North Korean RAT via AI Agent Auto-Install

Axios npm Supply Chain Attack: North Korean RAT via AI Agent Auto-Install is a critical-severity supply chain compromise issue in axios, a package. Affected: >=1.8.1 <1.8.3. Fixed in 1.8.3.

Is axios running on your developers' machines? Anomity inventories the AI agents, MCP servers, extensions and skills on every developer device, so you can see what this advisory touches. Detect this across your developers' devices with Anomity →

Key facts

ID
axios-npm-supply-chain-attack-north-korean-rat-via-ai-agent-auto-install
Severity
critical
Attack type
Supply chain compromise
Component
axios · package
Package
axios npm
Known exploited
No known exploitation
Published
Last verified

What is this vulnerability?

UNC1069 (North Korea-nexus) compromised the Axios npm maintainer's credentials and published two backdoored releases containing a phantom dependency that dropped a cross-platform RAT on macOS, Windows, and Linux. The attack specifically exploited AI coding agents (Claude Code, Cursor, GitHub Copilot Workspace) which autonomously run npm install without human confirmation, creating an estimated 179-minute silent compromise window before detection.

Affected versions

AffectedFixed in
>=1.8.1 <1.8.31.8.3

Am I affected by this vulnerability?

You are affected if you run axios >=1.8.1 <1.8.3. Versions 1.8.3 and later include the fix.

How do I fix it?

Pin Axios to 1.8.0 or upgrade to 1.8.3+. Audit node_modules for the phantom dependency 'axiosproxy'. Block autonomous npm install in CI policies. Scan for RAT C2 indicators (see Microsoft blog for IOCs).

References