Vulnerability high
CVSS
high
3.1/10

CVE-2026-102437 (ConfigPoisoning): Viewing a Diff in DeepSeek-Reasonix Studio Ran the Repository's git filter.clean Command

CVE-2026-102437 is a high-severity remote code execution issue (CVSS 3.1) in reasonix, a package. Affected: <1.39.3. Fixed in 2.21.0.

Is reasonix running on your developers' machines? Anomity inventories the AI agents, MCP servers, extensions and skills on every developer device, so you can see what this advisory touches. Detect this across your developers' devices with Anomity →

Key facts

ID
CVE-2026-102437
Aliases
GHSA-grg2-7gc6-36m6
Severity
high
CVSS score
3.1
Attack type
Remote code execution
Component
Reasonix Studio · package
Package
reasonix
Known exploited
No known exploitation
Published
Last verified

What is CVE-2026-102437?

GitLab's Threat Research Group (Abisheik Magesh, Daniel Abeles) published ConfigPoisoning on 2 October 2026. It is tracked as GHSA-grg2-7gc6-36m6, published by the maintainer on 29 September and rated critical, and as CVE-2026-102437, with GitLab as CNA and a CVSS 3.1 score of 7.8. DeepSeek-Reasonix's internal/gitcmd wrapper neutralized core.fsmonitor and maintenance.auto and passed --no-ext-diff and --no-textconv, but did nothing about filter.<driver>.clean, which .gitattributes selects per file; a comment in its own code named that gap. When a developer opened a file's diff in the Reasonix Studio desktop app, git ran the clean filter defined in the repository's .git/config to build the comparison blob, so the attacker's command ran once for each side of the diff. .gitattributes survives a clone but .git/config does not, so delivery needs an archive, a synced folder, a CI cache or a devcontainer build, or another compromised or prompt-injected agent on the machine writing the config into a normally cloned repository. Fixed in Reasonix Studio 2.21.0 and the reasonix npm package 1.39.3 on 30 September. GitLab says several other widely used coding agents have the same class of flaw and are under coordinated disclosure.

Affected versions

AffectedFixed in
<1.39.32.21.0

Am I affected by CVE-2026-102437?

You are affected if you run reasonix <1.39.3. Versions 2.21.0 and later include the fix.

How do I fix CVE-2026-102437?

Upgrade Reasonix Studio to 2.21.0 and the reasonix npm package to 1.39.3 or later. On older versions, do not open diffs in repositories that did not come from your own direct clone. Check .git/config in local repositories for filter.*.clean or smudge, diff.external, core.hooksPath, core.fsmonitor and core.sshCommand entries nobody set, especially in repositories extracted from archives or shared folders. Tools that run git against directories they do not control should override every command-running key on each call, or read blobs with git cat-file instead.

References