Vulnerability medium
CVSS
medium
6.8/10

GHSA-7xgj-8392-5q4r: FastMCP 3.4.10 and 4.1.2: Transformed Components Skipped Their Authorization Check, and the 4.x OAuth Client Credentials Providers Could Send the Client Secret to a Server-Chosen Authorization Server

GHSA-7xgj-8392-5q4r is a medium-severity authentication bypass issue (CVSS 6.8) in fastmcp, a MCP server. Affected: >=3.0.0 <3.4.10 || >=4.0.0 <4.1.2. Fixed in 3.4.10.

Is fastmcp running on your developers' machines? Anomity finds every device with this MCP server installed, shows the version, and can block it by policy. Detect this across your developers' devices with Anomity →

Key facts

ID
GHSA-7xgj-8392-5q4r
Severity
medium
CVSS score
6.8
Attack type
Authentication bypass
Component
fastmcp · MCP server
Package
fastmcp
Known exploited
No known exploitation
Published
Last verified

What is GHSA-7xgj-8392-5q4r?

PrefectHQ published two FastMCP advisories on 23 October 2026, both rated medium. GHSA-7xgj-8392-5q4r (CVSS 6.8): when a server transform changed the metadata a component's authorization policy reads, direct lookups checked the original component but returned the transformed one, so a client that knew the identifier could call a tool, or read a resource or prompt, that the policy denies; it affects 3.0.0 to 3.4.9 and 4.0.0 to 4.1.1. GHSA-vqqp-x5qm-5qp4 (CVSS 5.9): the client-side ClientCredentialsOAuthProvider and PrivateKeyJWTOAuthProvider in 4.0.0 to 4.1.1 did not bind credentials to the authorization server that issued them, so an untrusted or compromised MCP server could advertise its own authorization server and receive the client secret or a signed assertion. Upgrading alone does not fix the second: 4.1.2 adds an issuer parameter that has to be configured. Both packages, fastmcp and fastmcp-slim, are affected. This follows the critical FastMCP client code-execution fix a week earlier.

Affected versions

AffectedFixed in
>=3.0.0 <3.4.10 || >=4.0.0 <4.1.23.4.10

Am I affected by GHSA-7xgj-8392-5q4r?

You are affected if you run fastmcp >=3.0.0 <3.4.10 || >=4.0.0 <4.1.2. Versions 3.4.10 and later include the fix.

How do I fix GHSA-7xgj-8392-5q4r?

Upgrade fastmcp or fastmcp-slim to 3.4.10 or 4.1.2. On 4.1.2, set issuer on every ClientCredentialsOAuthProvider and PrivateKeyJWTOAuthProvider to the authorization server that issued the credentials, because leaving it out keeps the old behaviour with only a deprecation warning, and rotate client secrets that may have reached an MCP server you do not control. Until upgraded, enforce authorization at the handler or server boundary rather than in a policy whose inputs a transform changes, and avoid proxy templates that overlap protected resources.

How do I find every machine running fastmcp?

Anomity inventories the AI agents, MCP servers, IDE extensions and skills on each developer device, so you can see which machines run fastmcp and which version, then enforce a policy on it.

References